01/27/2020

Platform SDK 1.11 released

We released a new version of the Platform SDK to support developing for Engage 6.11 and above.

Starting with that Engage version, the webpack module is part of the theme and optimized to work with the specific frontend version in use.

In the past, the webpack module has been part of the SDK and had to be capable of building all versions of Engage. This added overhead to maintain compatibility. Now, the SDK detects if the theme contains the webpack module and uses that instead.

Note that you need to update your Platform SDK to version 1.11 if you want to develop with themes version 6.11 and above.

To install the latest version run:

npm i -g @shopgate/platform-sdk@latest

Author: Stefan Baldewein, Product Manager